<!doctype html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="https://gmpg.org/xfn/11">

	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v17.6 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Gen Zers discuss China-US Relations in China Daily series Youth Power - TopNews Philippines</title>
	<link rel="canonical" href="https://www.topnewsphil.com/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Gen Zers discuss China-US Relations in China Daily series Youth Power - TopNews Philippines" />
	<meta property="og:description" content="BEIJING, Dec. 30, 2021 /PRNewswire/ &#8212; The seventh episode of the China Daily series&nbsp;Youth Power, titled &#8220;Too Big to Fail—China-US Relations in the Eyes of Gen Z&#8221;, was broadcast online at 8 pm Beijing time (7 am EST), on Thursday, Dec 30. For the episode, Youth Power&nbsp;interviewed young people on the streets of China and [&hellip;]" />
	<meta property="og:url" content="https://www.topnewsphil.com/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power/" />
	<meta property="og:site_name" content="TopNews Philippines" />
	<meta property="article:published_time" content="2021-12-30T13:10:00+00:00" />
	<meta property="og:image" content="https://c212.net/c/img/favicon.png?sn=CN18119&#038;sd=2021-12-30" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="admin" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="4 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.topnewsphil.com/#website","url":"https://www.topnewsphil.com/","name":"TopNews Philippines","description":"Updated News in PH","publisher":{"@id":"https://www.topnewsphil.com/#/schema/person/6d25aca1d341842268e7ce34fe7969fa"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.topnewsphil.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.topnewsphil.com/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power/#primaryimage","inLanguage":"en-US","url":"https://www.topnewsphil.com/wp-content/uploads/2021/12/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power.png","contentUrl":"https://www.topnewsphil.com/wp-content/uploads/2021/12/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power.png","width":16,"height":16},{"@type":"WebPage","@id":"https://www.topnewsphil.com/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power/#webpage","url":"https://www.topnewsphil.com/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power/","name":"Gen Zers discuss China-US Relations in China Daily series Youth Power - TopNews Philippines","isPartOf":{"@id":"https://www.topnewsphil.com/#website"},"primaryImageOfPage":{"@id":"https://www.topnewsphil.com/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power/#primaryimage"},"datePublished":"2021-12-30T13:10:00+00:00","dateModified":"2021-12-30T13:10:00+00:00","breadcrumb":{"@id":"https://www.topnewsphil.com/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.topnewsphil.com/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power/"]}]},{"@type":"BreadcrumbList","@id":"https://www.topnewsphil.com/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.topnewsphil.com/"},{"@type":"ListItem","position":2,"name":"Gen Zers discuss China-US Relations in China Daily series Youth Power"}]},{"@type":"Article","@id":"https://www.topnewsphil.com/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power/#article","isPartOf":{"@id":"https://www.topnewsphil.com/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power/#webpage"},"author":{"@id":"https://www.topnewsphil.com/#/schema/person/6d25aca1d341842268e7ce34fe7969fa"},"headline":"Gen Zers discuss China-US Relations in China Daily series Youth Power","datePublished":"2021-12-30T13:10:00+00:00","dateModified":"2021-12-30T13:10:00+00:00","mainEntityOfPage":{"@id":"https://www.topnewsphil.com/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power/#webpage"},"wordCount":714,"commentCount":0,"publisher":{"@id":"https://www.topnewsphil.com/#/schema/person/6d25aca1d341842268e7ce34fe7969fa"},"image":{"@id":"https://www.topnewsphil.com/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power/#primaryimage"},"thumbnailUrl":"https://www.topnewsphil.com/wp-content/uploads/2021/12/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power.png","articleSection":["PRN Asia"],"inLanguage":"en-US"},{"@type":["Person","Organization"],"@id":"https://www.topnewsphil.com/#/schema/person/6d25aca1d341842268e7ce34fe7969fa","name":"admin","image":{"@type":"ImageObject","@id":"https://www.topnewsphil.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/d56271b1587bd73bf8943c5ff2cecc36?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/d56271b1587bd73bf8943c5ff2cecc36?s=96&d=mm&r=g","caption":"admin"},"logo":{"@id":"https://www.topnewsphil.com/#personlogo"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.youtube.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="TopNews Philippines &raquo; Feed" href="https://www.topnewsphil.com/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.topnewsphil.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.topnewsphil.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='wpda_youtube_gutenberg_css-css'  href='https://www.topnewsphil.com/wp-content/plugins/youtube-video-player/admin/gutenberg/style.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='color-blog-fonts-css'  href='https://fonts.googleapis.com/css?family=Josefin+Sans%3A400%2C700%7CPoppins%3A300%2C400%2C400i%2C500%2C700&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.topnewsphil.com/wp-content/themes/color-blog/assets/library/font-awesome/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='lightslider-style-css'  href='https://www.topnewsphil.com/wp-content/themes/color-blog/assets/library/lightslider/css/lightslider.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='animate-css'  href='https://www.topnewsphil.com/wp-content/themes/color-blog/assets/library/animate/animate.min.css?ver=3.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='preloader-css'  href='https://www.topnewsphil.com/wp-content/themes/color-blog/assets/css/mt-preloader.css?ver=1.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='color-blog-style-css'  href='https://www.topnewsphil.com/wp-content/themes/color-blog/style.css?ver=1.1.0' type='text/css' media='all' />
<style id='color-blog-style-inline-css' type='text/css'>
.category-button.cb-cat-5 a{background:#dd3333}
.category-button.cb-cat-5 a:hover{background:#ab0101}
#site-navigation ul li.cb-cat-5 .menu-item-description{background:#dd3333}
#site-navigation ul li.cb-cat-5 .menu-item-description:after{border-top-color:#dd3333}
.category-button.cb-cat-8 a{background:#76dd63}
.category-button.cb-cat-8 a:hover{background:#44ab31}
#site-navigation ul li.cb-cat-8 .menu-item-description{background:#76dd63}
#site-navigation ul li.cb-cat-8 .menu-item-description:after{border-top-color:#76dd63}
.category-button.cb-cat-10 a{background:#3b2d1b}
.category-button.cb-cat-10 a:hover{background:#090000}
#site-navigation ul li.cb-cat-10 .menu-item-description{background:#3b2d1b}
#site-navigation ul li.cb-cat-10 .menu-item-description:after{border-top-color:#3b2d1b}
.category-button.cb-cat-4 a{background:#e29166}
.category-button.cb-cat-4 a:hover{background:#b05f34}
#site-navigation ul li.cb-cat-4 .menu-item-description{background:#e29166}
#site-navigation ul li.cb-cat-4 .menu-item-description:after{border-top-color:#e29166}
.category-button.cb-cat-7 a{background:#f20058}
.category-button.cb-cat-7 a:hover{background:#c00026}
#site-navigation ul li.cb-cat-7 .menu-item-description{background:#f20058}
#site-navigation ul li.cb-cat-7 .menu-item-description:after{border-top-color:#f20058}
.category-button.cb-cat-9 a{background:#3b2d1b}
.category-button.cb-cat-9 a:hover{background:#090000}
#site-navigation ul li.cb-cat-9 .menu-item-description{background:#3b2d1b}
#site-navigation ul li.cb-cat-9 .menu-item-description:after{border-top-color:#3b2d1b}
.category-button.cb-cat-2 a{background:#332663}
.category-button.cb-cat-2 a:hover{background:#010031}
#site-navigation ul li.cb-cat-2 .menu-item-description{background:#332663}
#site-navigation ul li.cb-cat-2 .menu-item-description:after{border-top-color:#332663}
.category-button.cb-cat-1 a{background:#3b2d1b}
.category-button.cb-cat-1 a:hover{background:#090000}
#site-navigation ul li.cb-cat-1 .menu-item-description{background:#3b2d1b}
#site-navigation ul li.cb-cat-1 .menu-item-description:after{border-top-color:#3b2d1b}
a,a:hover,a:focus,a:active,.entry-cat .cat-links a:hover,.entry-cat a:hover,.entry-footer a:hover,.comment-author .fn .url:hover,.commentmetadata .comment-edit-link,#cancel-comment-reply-link,#cancel-comment-reply-link:before,.logged-in-as a,.widget a:hover,.widget a:hover::before,.widget li:hover::before,.mt-social-icon-wrap li a:hover,#site-navigation ul li:hover>a,#site-navigation ul li.current-menu-item>a,#site-navigation ul li.current_page_ancestor>a,#site-navigation ul li.current-menu-ancestor>a,#site-navigation ul li.current_page_item>a,#site-navigation ul li.focus>a,.banner-sub-title,.entry-title a:hover,.cat-links a:hover,.entry-footer .mt-readmore-btn:hover,.btn-wrapper a:hover,.mt-readmore-btn:hover,.navigation.pagination .nav-links .page-numbers.current,.navigation.pagination .nav-links a.page-numbers:hover,#footer-menu li a:hover,.color_blog_latest_posts .mt-post-title a:hover,#mt-scrollup:hover,.menu-toggle:hover,#top-navigation ul li a:hover,.mt-search-icon:hover,.entry-meta a:hover,.front-slider-block .banner-title a:hover,.post-info-wrap .entry-meta a:hover,.single .mt-single-related-posts .entry-title a:hover,.breadcrumbs .trail-items li a:hover,.wrap-label i,.has-thumbnail .post-info-wrap .entry-title a:hover,.front-slider-block .post-info-wrap .entry-title a:hover{color:#FFB300}
.widget_search .search-submit,.widget_search .search-submit:hover,.navigation.pagination .nav-links .page-numbers.current,.navigation.pagination .nav-links a.page-numbers:hover,.error-404.not-found,.color_blog_social_media a:hover,.custom-header{border-color:#FFB300}
.front-slider-block .lSAction > a:hover,.top-featured-post-wrap .post-thumbnail .post-number,.post-cats-list a,#site-navigation .menu-item-description,article .post-thumbnail::before,#secondary .widget .widget-title::before,.mt-related-post-title::before,#colophon .widget .widget-title::before,.features-post-title::before,.mt-menu-search .mt-form-wrap .search-form .search-submit{background:#FFB300}
.edit-link .post-edit-link,.reply .comment-reply-link,.widget_search .search-submit,.mt-menu-search .mt-form-wrap .search-form .search-submit:hover,article.sticky::before{background:#FFB300}
</style>
<link rel='stylesheet' id='color-blog-responsive-style-css'  href='https://www.topnewsphil.com/wp-content/themes/color-blog/assets/css/mt-responsive.css?ver=1.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.topnewsphil.com/wp-includes/css/dashicons.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://www.topnewsphil.com/wp-includes/js/thickbox/thickbox.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='front_end_youtube_style-css'  href='https://www.topnewsphil.com/wp-content/plugins/youtube-video-player/front_end/styles/baze_styles_youtube.css?ver=5.8.2' type='text/css' media='all' />
<script type='text/javascript' src='https://www.topnewsphil.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.topnewsphil.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.topnewsphil.com/wp-content/plugins/youtube-video-player/front_end/scripts/youtube_embed_front_end.js?ver=5.8.2' id='youtube_front_end_api_js-js'></script>
<script type='text/javascript' src='https://www.youtube.com/iframe_api?ver=5.8.2' id='youtube_api_js-js'></script>
<link rel="https://api.w.org/" href="https://www.topnewsphil.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.topnewsphil.com/wp-json/wp/v2/posts/102922" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.topnewsphil.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.topnewsphil.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.2" />
<link rel='shortlink' href='https://www.topnewsphil.com/?p=102922' />
<link rel="alternate" type="application/json+oembed" href="https://www.topnewsphil.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.topnewsphil.com%2Fgen-zers-discuss-china-us-relations-in-china-daily-series-youth-power%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.topnewsphil.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.topnewsphil.com%2Fgen-zers-discuss-china-us-relations-in-china-daily-series-youth-power%2F&#038;format=xml" />
</head>

<body data-rsssl=1 class="post-template-default single single-post postid-102922 single-format-standard site-layout--wide right-sidebar">

        <div id="preloader-background">
            <div class="preloader-wrapper">
                <div class="sk-spinner sk-spinner-pulse"></div>
            </div><!-- .preloader-wrapper -->
        </div><!-- #preloader-background -->

<div id="page" class="site">
<a class="skip-link screen-reader-text" href="#content">Skip To Content</a>
	<div id="top-header" class="top-header-wrap mt-clearfix"><div class="mt-container">        <div class="trending-wrapper tag-before-icon">
                <span class="wrap-label"><i class="fa fa-bolt" aria-hidden="true"></i> Trending Now</span>
                <div class="tags-wrapper">
					                </div><!-- .tags-wrapper -->
        </div><!-- .trending-wrapper -->
		<div class="top-header-nav">
			<nav itemscope id="top-navigation" class="main-navigation">
				<div class="menu-topnews-container"><ul id="top-header-menu" class="menu"><li id="menu-item-8" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-8"><a href="https://www.topnewsphil.com/">Home</a></li>
<li id="menu-item-9" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9 cb-cat-2"><a href="https://www.topnewsphil.com/category/topnews/">TopNews</a></li>
<li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12 cb-cat-4"><a href="https://www.topnewsphil.com/category/music/">Music</a></li>
<li id="menu-item-74" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-74 cb-cat-5"><a href="https://www.topnewsphil.com/category/entertainment/">Entertainment</a></li>
<li id="menu-item-85" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85 cb-cat-7"><a href="https://www.topnewsphil.com/category/planets/">Planets</a></li>
<li id="menu-item-139" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-139 cb-cat-8"><a href="https://www.topnewsphil.com/category/health/">Health</a></li>
<li id="menu-item-52748" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52748 cb-cat-10"><a href="https://www.topnewsphil.com/category/media-outreach/">Media OutReach</a></li>
<li id="menu-item-8865" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8865 cb-cat-9"><a href="https://www.topnewsphil.com/category/prn-asia/">PRN Asia</a></li>
<li id="menu-item-136" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136"><a href="https://www.topnewsphil.com/privacy-policy-2/">Privacy Policy</a></li>
</ul></div>			</nav><!-- #site-navigation -->
		</div><!-- .top-header-nav -->
</div><!-- mt-container --></div><!-- #top-header --><header id="masthead" class="site-header"><div class="mt-logo-row-wrapper mt-clearfix">		<div class="logo-ads-wrap">
			<div class="mt-container">
				<div class="site-branding">
												<p class="site-title"><a href="https://www.topnewsphil.com/" rel="home">TopNews Philippines</a></p>
												<p class="site-description">Updated News in PH</p>
									</div><!-- .site-branding -->
				<div class="header-widget-wrapper">
					<section id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- pbcremixleaderboard1 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-3836661179847994"
     data-ad-slot="6181166265"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></section>				</div>
			</div> <!-- mt-container -->
		</div><!-- .logo-ads-wrap -->
<div class="mt-social-menu-wrapper"><div class="mt-container">		<div class="menu-toggle"><a href="javascript:void(0)"><i class="fa fa-navicon"></i>Menu</a></div>
		<nav itemscope id="site-navigation" class="main-navigation">
			<div class="menu-topnews-container"><ul id="primary-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-8"><a href="https://www.topnewsphil.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9 cb-cat-2"><a href="https://www.topnewsphil.com/category/topnews/">TopNews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12 cb-cat-4"><a href="https://www.topnewsphil.com/category/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-74 cb-cat-5"><a href="https://www.topnewsphil.com/category/entertainment/">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85 cb-cat-7"><a href="https://www.topnewsphil.com/category/planets/">Planets</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-139 cb-cat-8"><a href="https://www.topnewsphil.com/category/health/">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52748 cb-cat-10"><a href="https://www.topnewsphil.com/category/media-outreach/">Media OutReach</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8865 cb-cat-9"><a href="https://www.topnewsphil.com/category/prn-asia/">PRN Asia</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136"><a href="https://www.topnewsphil.com/privacy-policy-2/">Privacy Policy</a></li>
</ul></div>		</nav><!-- #site-navigation -->
<div class="mt-social-search-wrapper">		<div class="mt-social-wrapper">
			<span class="mt-follow-title">Follow Us: </span>
						<ul class="mt-social-icon-wrap">
											<li class="mt-social-icon">
								<a href="http://facebook.com/topnewsphil" target="_blank">
									<i class="fa fa-facebook-square"></i>
								</a>
							</li>
											<li class="mt-social-icon">
								<a href="#" target="_blank">
									<i class="fa fa-pinterest"></i>
								</a>
							</li>
							</ul>
		</div>
		<div class="mt-menu-search">
			<div class="mt-search-icon"><a href="javascript:void(0)">Search<i class="fa fa-search"></i></a></div>
			<div class="mt-form-wrap">
				<div class="mt-form-close"><a href="javascript:void(0)"><i class="fa fa-close"></i></a></div>
				<form role="search" method="get" class="search-form" action="https://www.topnewsphil.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>			</div><!-- .mt-form-wrap -->
		</div><!-- .mt-menu-search -->
</div><!-- .mt-social-search-wrapper --></div><!--.mt-container --></div><!--.mt-social-menu-wrapper --></div><!--.mt-logo-row-wrapper --></header><!-- #masthead -->		<div class="custom-header has-bg-img"  style="background-image:url(https://www.topnewsphil.com/wp-content/uploads/2019/12/topnews.jpg);background-size:cover;" >
            <div class="mt-container">
<h1 class="entry-title">Gen Zers discuss China-US Relations in China Daily series Youth Power</h1>		<nav id="breadcrumb" class="mt-breadcrumb">
			<div role="navigation" aria-label="Breadcrumbs" class="breadcrumb-trail breadcrumbs" itemprop="breadcrumb"><div class="mt-container"><ul class="trail-items" itemscope itemtype="http://schema.org/BreadcrumbList"><meta name="numberOfItems" content="3" /><meta name="itemListOrder" content="Ascending" /><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-begin"><a href="https://www.topnewsphil.com/" rel="home" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item"><a href="https://www.topnewsphil.com/category/prn-asia/" itemprop="item"><span itemprop="name">PRN Asia</span></a><meta itemprop="position" content="2" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-end"><span itemprop="name"><span itemprop="name">Gen Zers discuss China-US Relations in China Daily series Youth Power</span></span><meta itemprop="position" content="3" /></li></ul></div></div>		</nav>
			</div><!-- .mt-container -->
		</div><!-- .custom-header -->

	<div id="content" class="site-content">
		<div class="mt-container">
<div class="mt-page-content-wrapper">
	<div itemscope id="primary" class="content-area">
		<main id="main" class="site-main">
		
<article id="post-102922" class="has-thumbnail post-102922 post type-post status-publish format-standard has-post-thumbnail hentry category-prn-asia">
	<div class="post-thumbnail">
		<img width="16" height="16" src="https://www.topnewsphil.com/wp-content/uploads/2021/12/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power.png" class="attachment-full size-full wp-post-image" alt="" loading="lazy" />		<div class="post-info-wrap">
			<div class="post-cat">			<div class="post-cats-list">
										<span class="category-button cb-cat-9"><a href="https://www.topnewsphil.com/category/prn-asia/">PRN Asia</a></span>
							</div><!-- .post-cats-list --></div>
			<div class="entry-meta"> 
				<span class="posted-on"><a href="https://www.topnewsphil.com/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power/" rel="bookmark"><time class="entry-date published updated" datetime="2021-12-30T13:10:00+00:00">December 30, 2021</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://www.topnewsphil.com/author/admin/">admin</a></span></span> 
			</div>
			<h3 class="entry-title"><a href="https://www.topnewsphil.com/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power/" rel="bookmark">Gen Zers discuss China-US Relations in China Daily series Youth Power</a></h3>	    </div><!--.post-info-wrap -->
	</div><!-- .post-thumbnail -->

	<div class="entry-content">
		
<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="f2f3ef1a5a9aa1e0e49b16dbd537678c" data-index="2" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- pbcremixleaderboard1 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-3836661179847994"
     data-ad-slot="6181166265"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p><span class="xn-location">BEIJING</span>, <span class="xn-chron">Dec. 30, 2021</span> /PRNewswire/ &#8212; The seventh episode of the China Daily series<i>&nbsp;Youth Power</i>, titled &#8220;Too Big to Fail<span id="spanHghlt4e68">—</span>China-US Relations in the Eyes of Gen Z&#8221;, was broadcast online at <span class="xn-chron">8 pm</span> <span class="xn-location">Beijing</span> <span id="spanHghlt2440">time</span> (<span class="xn-chron">7 am EST</span>), on <span class="xn-chron">Thursday, Dec 30</span>. </p>
<p>For the episode, <i>Y</i><i>outh Power</i>&nbsp;interviewed young people on the streets of <span class="xn-location">China</span> and the US and talked about politics, culture, economics, education and other topics. Gen Zers from both <span class="xn-location">China</span> and the US were also invited to sit down and give their views on the China-US relationship.</p>
<p>&#8220;I think the future is really in our hands. We really need to like one by one work towards a certain way, because if we do nothing, then nothing&#8217;s gonna happen. And if we hold back and stay how we are now, we&#8217;re gonna stay in the same situation or make it worse. I think we all have to take a progressive thinking. And it&#8217;s not just towards US-China relations. It&#8217;s the relations with the whole world.&#8221; claimed <span class="xn-person">Amy Nicole</span>, a student in Tsinghua University.</p>
<p>Yuan Ziyi, 21, a junior student at Fudan University in <span class="xn-location">Shanghai</span>, compared the relationship to that of a married couple always bickering with one another. &#8220;The youth of <span class="xn-location">China</span> and the US should both shoulder the responsibility of building a community of a shared future for humankind.&#8221; Yuan said.</p>
<p>Ouyang Liaoxin, 22, a postgraduate at Shanghai International Studies University, said: &#8220;So if I have to say one sentence to those people with hostility against <span class="xn-location">China</span>, I would say that fear comes from ignorance. It could be expensive or complicated for you to actually come to <span class="xn-location">China</span>, but what you can do is to hear our voices, listen to what we are saying, listen to what we&#8217;re saying right now.&#8221;</p>
<p>Perhaps not surprisingly, they did not see eye to eye on some issues, but one thing they did agree on was that <span class="xn-location">China</span> and the US depend on one another, that it is in both their interests to work together and that being at loggerheads can only be harmful to them and the world as a whole. </p>
<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="f2f3ef1a5a9aa1e0e49b16dbd537678c" data-index="1" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- pbcremix460x15 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:468px;height:15px"
     data-ad-client="ca-pub-3836661179847994"
     data-ad-slot="5407390661"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<p><span class="xn-person">Dylan Austin Walker</span>, 25, who is studying at Beijing Language and Culture University, had some words of advice for young people in the two countries. &#8220;The future of <span class="xn-location">China</span> and the US, for a large part, rests on the shoulders of Chinese and American youth. Only when we unite and put the common interests of our nations and people together will we be able to create healthier China-US relations.&#8221; </p>
<p><span class="xn-person">Peter Joseph Scheuer Jr</span>, a student at Tsinghua University, told of his playing with the US youth table tennis team and his studying and training at Tsinghua. &#8220;I will do my best to make it through the trials to be on the US team for the World Championships and the Olympic squad,&#8221; he said.</p>
<p><span class="xn-person">Miriam Frank</span>, 26, a lecturer at Renmin University of China&nbsp;in Beijing,&nbsp;<span id="spanHghlt921f">has</span> traveled to nearly every province in <span class="xn-location">China</span> since 2013.&nbsp;She noted that we should not&nbsp;be closed-minded to other cultures, especially if we were able to understand another culture and to communicate with the people of that country could really help improve certain aspects. </p>
<p>If one compares <span class="xn-location">China</span> and the US to two ships on the world&#8217;s mighty oceans it is not hard to see Generation Z as young sailors on these ships&nbsp;&#8211; sailors who will one day take the helm. One thing these sailors have in common is unbridled enthusiasm and optimism. The world may not know exactly what course they have plotted, but it is hoped that&nbsp;they will be a worthy match for the toughest weather and the tallest waves that the human race will encounter.</p>
<p><i>Youth Power </i>is an online program developed by China Daily since June, conceived with the interests and ideals of Generation Z&nbsp;in mind, and aims to provide an insight into the perspectives of young people on the state of the world and where it is heading, encouraging them to think about issues and motivating them to play their role in making the world a better place. The previous six episodes attracted more than 700 million views.</p>
<p id="PURL"><img loading="lazy" title="Cision" width="12" height="12" alt="Cision" src="https://c212.net/c/img/favicon.png?sn=CN18119&amp;sd=2021-12-30"> View original content:<a id="PRNURL" rel="nofollow noopener" href="https://www.prnewswire.com/news-releases/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power-301451785.html" target="_blank">https://www.prnewswire.com/news-releases/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power-301451785.html</a></p>

<div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div>	</div> <!-- .entry-content -->

	<footer class="entry-footer">
			</footer><!-- .entry-footer -->
	
<div class="mt-author-box">
			<div itemprop="image" class="mt-author__avatar">
			<img alt='' src='https://secure.gravatar.com/avatar/d56271b1587bd73bf8943c5ff2cecc36?s=96&#038;d=mm&#038;r=g' class='avatar avatar-96 photo' height='96' width='96' loading='lazy' />		</div><!-- .mt-author-avatar -->
	
	<div class="mt-author-info">
						<h5 itemprop="name" class="mt-author-name"><a href="https://www.topnewsphil.com/author/admin/" title="Posts by admin" rel="author">admin</a></h5>
		
		
		<div class="mt-author-meta">
					</div><!-- .mt-author-meta -->
	</div><!-- .mt-author-info -->
</div><!-- .mt-author-bio --></article><!-- #post-102922 -->
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.topnewsphil.com/inspiration-capital-partners-closes-investment-in-beijing-value-simplex-technology-co-ltd/" rel="prev">Inspiration Capital Partners Closes Investment in Beijing Value Simplex Technology Co. Ltd.</a></div><div class="nav-next"><a href="https://www.topnewsphil.com/infobird-co-ltd-announces-filing-of-interim-report-on-form-6-k/" rel="next">Infobird Co., Ltd Announces Filing of Interim Report on Form 6-K</a></div></div>
	</nav>	<section class="mt-single-related-posts">
		<h2 class="mt-related-post-title">Related Posts</h2>

		<div class="mt-related-posts-wrapper">
			
<article id="post-102926" class="has-thumbnail wow fadeInUp post-102926 post type-post status-publish format-standard has-post-thumbnail hentry category-prn-asia">
	<div class="thumb-cat-wrap">
			<div class="post-thumbnail">
				<img width="16" height="16" src="https://www.topnewsphil.com/wp-content/uploads/2021/12/ai-technology-to-contribute-up-to-70-of-carbon-emissions-reductions-by-2060-idc-and-baidu-white-paper.png" class="attachment-color-blog-full-width size-color-blog-full-width wp-post-image" alt="" loading="lazy" />			</div><!-- .post-thumbnail -->

					<div class="post-cats-list">
										<span class="category-button cb-cat-9"><a href="https://www.topnewsphil.com/category/prn-asia/">PRN Asia</a></span>
							</div><!-- .post-cats-list --></div><!-- .thumb-cat-wrap -->		<div class="entry-cat">
			<span class="posted-on"><a href="https://www.topnewsphil.com/ai-technology-to-contribute-up-to-70-of-carbon-emissions-reductions-by-2060-idc-and-baidu-white-paper/" rel="bookmark"><time class="entry-date published updated" datetime="2021-12-30T13:43:00+00:00">December 30, 2021</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://www.topnewsphil.com/author/admin/">admin</a></span></span>		</div><!-- .entry-meta -->
	
	<header class="entry-header">
		<h2 class="entry-title"><a href="https://www.topnewsphil.com/ai-technology-to-contribute-up-to-70-of-carbon-emissions-reductions-by-2060-idc-and-baidu-white-paper/" rel="bookmark">AI TECHNOLOGY TO CONTRIBUTE UP TO 70% OF CARBON EMISSIONS REDUCTIONS BY 2060: IDC AND BAIDU WHITE PAPER</a></h2>	</header><!-- .entry-header -->	

	<footer class="entry-footer">
			</footer><!-- .entry-footer -->
</article><!-- #post-102926 -->
<article id="post-102928" class="has-thumbnail wow fadeInUp post-102928 post type-post status-publish format-standard has-post-thumbnail hentry category-prn-asia">
	<div class="thumb-cat-wrap">
			<div class="post-thumbnail">
				<img width="16" height="16" src="https://www.topnewsphil.com/wp-content/uploads/2021/12/infobird-co-ltd-announces-filing-of-interim-report-on-form-6-k.png" class="attachment-color-blog-full-width size-color-blog-full-width wp-post-image" alt="" loading="lazy" />			</div><!-- .post-thumbnail -->

					<div class="post-cats-list">
										<span class="category-button cb-cat-9"><a href="https://www.topnewsphil.com/category/prn-asia/">PRN Asia</a></span>
							</div><!-- .post-cats-list --></div><!-- .thumb-cat-wrap -->		<div class="entry-cat">
			<span class="posted-on"><a href="https://www.topnewsphil.com/infobird-co-ltd-announces-filing-of-interim-report-on-form-6-k/" rel="bookmark"><time class="entry-date published updated" datetime="2021-12-30T13:30:00+00:00">December 30, 2021</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://www.topnewsphil.com/author/admin/">admin</a></span></span>		</div><!-- .entry-meta -->
	
	<header class="entry-header">
		<h2 class="entry-title"><a href="https://www.topnewsphil.com/infobird-co-ltd-announces-filing-of-interim-report-on-form-6-k/" rel="bookmark">Infobird Co., Ltd Announces Filing of Interim Report on Form 6-K</a></h2>	</header><!-- .entry-header -->	

	<footer class="entry-footer">
			</footer><!-- .entry-footer -->
</article><!-- #post-102928 -->
<article id="post-102924" class="has-thumbnail wow fadeInUp post-102924 post type-post status-publish format-standard has-post-thumbnail hentry category-prn-asia">
	<div class="thumb-cat-wrap">
			<div class="post-thumbnail">
				<img width="144" height="100" src="https://www.topnewsphil.com/wp-content/uploads/2021/12/inspiration-capital-partners-closes-investment-in-beijing-value-simplex-technology-co-ltd.png" class="attachment-color-blog-full-width size-color-blog-full-width wp-post-image" alt="" loading="lazy" />			</div><!-- .post-thumbnail -->

					<div class="post-cats-list">
										<span class="category-button cb-cat-9"><a href="https://www.topnewsphil.com/category/prn-asia/">PRN Asia</a></span>
							</div><!-- .post-cats-list --></div><!-- .thumb-cat-wrap -->		<div class="entry-cat">
			<span class="posted-on"><a href="https://www.topnewsphil.com/inspiration-capital-partners-closes-investment-in-beijing-value-simplex-technology-co-ltd/" rel="bookmark"><time class="entry-date published updated" datetime="2021-12-30T12:33:00+00:00">December 30, 2021</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://www.topnewsphil.com/author/admin/">admin</a></span></span>		</div><!-- .entry-meta -->
	
	<header class="entry-header">
		<h2 class="entry-title"><a href="https://www.topnewsphil.com/inspiration-capital-partners-closes-investment-in-beijing-value-simplex-technology-co-ltd/" rel="bookmark">Inspiration Capital Partners Closes Investment in Beijing Value Simplex Technology Co. Ltd.</a></h2>	</header><!-- .entry-header -->	

	<footer class="entry-footer">
			</footer><!-- .entry-footer -->
</article><!-- #post-102924 -->		</div><!-- .mt-related-posts-wrapper -->
	</section><!-- .mt-single-related-posts -->
		</main><!-- #main -->
	</div><!-- #primary -->
	<aside id="secondary" class="widget-area">
	<section id="custom_html-9" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe src="https://radio.hostsailor.com/public/topnewsphil/embed" frameborder="0" allowtransparency="true" style="width: 100%; min-height: 150px; border: 0;"></iframe>
</div></section><section id="youtube_embed_widget-2" class="widget youtube_embed_widget"><h4 class="widget-title">Youtube Channel</h4><div style="text-align:left"><span style="display:inline-block;text-align:center;"><iframe class="youtube_embed_iframe"    allowFullScreen="true" style="width:320px; height:265px" src="//www.youtube.com/embed/W1OeVc0nOXE?autoplay=0&theme=dark&loop=0&fs=1&modestbranding=0&iv_load_policy=3&color=red&autohide=1&disablekb=0&enablejsapi=1&version=3"></iframe><div></div></span></div></section><section id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- pbcremix2 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-3836661179847994"
     data-ad-slot="4420498663"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></section><section id="color_blog_latest_posts-4" class="widget color_blog_latest_posts">            <div class="mt-latest-posts-wrapper">
                                <div class="mt-posts-content-wrapper">
                                                    <div class="mt-single-post-wrap">
                                                                            <a href="https://www.topnewsphil.com/ai-technology-to-contribute-up-to-70-of-carbon-emissions-reductions-by-2060-idc-and-baidu-white-paper/" title="AI TECHNOLOGY TO CONTRIBUTE UP TO 70% OF CARBON EMISSIONS REDUCTIONS BY 2060: IDC AND BAIDU WHITE PAPER">
                                            <figure><div class="mt-post-thumb"><img width="16" height="16" src="https://www.topnewsphil.com/wp-content/uploads/2021/12/ai-technology-to-contribute-up-to-70-of-carbon-emissions-reductions-by-2060-idc-and-baidu-white-paper.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></div></figure>
                                        </a>
                                                                        <div class="mt-post-content">
                                        <h5 class="mt-post-title"><a href="https://www.topnewsphil.com/ai-technology-to-contribute-up-to-70-of-carbon-emissions-reductions-by-2060-idc-and-baidu-white-paper/">AI TECHNOLOGY TO CONTRIBUTE UP TO 70% OF CARBON EMISSIONS REDUCTIONS BY 2060: IDC AND BAIDU WHITE PAPER</a></h5>
                                        <div class="entry-cat">
                                            <span class="posted-on"><a href="https://www.topnewsphil.com/ai-technology-to-contribute-up-to-70-of-carbon-emissions-reductions-by-2060-idc-and-baidu-white-paper/" rel="bookmark"><time class="entry-date published updated" datetime="2021-12-30T13:43:00+00:00">December 30, 2021</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://www.topnewsphil.com/author/admin/">admin</a></span></span>                                        </div>
                                                                            </div>
                                </div><!-- .mt-single-post-wrap -->
                                                    <div class="mt-single-post-wrap">
                                                                            <a href="https://www.topnewsphil.com/infobird-co-ltd-announces-filing-of-interim-report-on-form-6-k/" title="Infobird Co., Ltd Announces Filing of Interim Report on Form 6-K">
                                            <figure><div class="mt-post-thumb"><img width="16" height="16" src="https://www.topnewsphil.com/wp-content/uploads/2021/12/infobird-co-ltd-announces-filing-of-interim-report-on-form-6-k.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></div></figure>
                                        </a>
                                                                        <div class="mt-post-content">
                                        <h5 class="mt-post-title"><a href="https://www.topnewsphil.com/infobird-co-ltd-announces-filing-of-interim-report-on-form-6-k/">Infobird Co., Ltd Announces Filing of Interim Report on Form 6-K</a></h5>
                                        <div class="entry-cat">
                                            <span class="posted-on"><a href="https://www.topnewsphil.com/infobird-co-ltd-announces-filing-of-interim-report-on-form-6-k/" rel="bookmark"><time class="entry-date published updated" datetime="2021-12-30T13:30:00+00:00">December 30, 2021</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://www.topnewsphil.com/author/admin/">admin</a></span></span>                                        </div>
                                                                            </div>
                                </div><!-- .mt-single-post-wrap -->
                                                    <div class="mt-single-post-wrap">
                                                                            <a href="https://www.topnewsphil.com/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power/" title="Gen Zers discuss China-US Relations in China Daily series Youth Power">
                                            <figure><div class="mt-post-thumb"><img width="16" height="16" src="https://www.topnewsphil.com/wp-content/uploads/2021/12/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></div></figure>
                                        </a>
                                                                        <div class="mt-post-content">
                                        <h5 class="mt-post-title"><a href="https://www.topnewsphil.com/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power/">Gen Zers discuss China-US Relations in China Daily series Youth Power</a></h5>
                                        <div class="entry-cat">
                                            <span class="posted-on"><a href="https://www.topnewsphil.com/gen-zers-discuss-china-us-relations-in-china-daily-series-youth-power/" rel="bookmark"><time class="entry-date published updated" datetime="2021-12-30T13:10:00+00:00">December 30, 2021</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://www.topnewsphil.com/author/admin/">admin</a></span></span>                                        </div>
                                                                            </div>
                                </div><!-- .mt-single-post-wrap -->
                                                    <div class="mt-single-post-wrap">
                                                                            <a href="https://www.topnewsphil.com/inspiration-capital-partners-closes-investment-in-beijing-value-simplex-technology-co-ltd/" title="Inspiration Capital Partners Closes Investment in Beijing Value Simplex Technology Co. Ltd.">
                                            <figure><div class="mt-post-thumb"><img width="144" height="100" src="https://www.topnewsphil.com/wp-content/uploads/2021/12/inspiration-capital-partners-closes-investment-in-beijing-value-simplex-technology-co-ltd.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></div></figure>
                                        </a>
                                                                        <div class="mt-post-content">
                                        <h5 class="mt-post-title"><a href="https://www.topnewsphil.com/inspiration-capital-partners-closes-investment-in-beijing-value-simplex-technology-co-ltd/">Inspiration Capital Partners Closes Investment in Beijing Value Simplex Technology Co. Ltd.</a></h5>
                                        <div class="entry-cat">
                                            <span class="posted-on"><a href="https://www.topnewsphil.com/inspiration-capital-partners-closes-investment-in-beijing-value-simplex-technology-co-ltd/" rel="bookmark"><time class="entry-date published updated" datetime="2021-12-30T12:33:00+00:00">December 30, 2021</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://www.topnewsphil.com/author/admin/">admin</a></span></span>                                        </div>
                                                                            </div>
                                </div><!-- .mt-single-post-wrap -->
                                                    <div class="mt-single-post-wrap">
                                                                            <a href="https://www.topnewsphil.com/china-medical-system-867-hks-latest-msci-esg-rating-unchanged-at-aa-leading-the-industry-globally/" title="China Medical System (867.HK)&#8217;s Latest MSCI ESG Rating Unchanged at AA, Leading the Industry Globally">
                                            <figure><div class="mt-post-thumb"><img width="16" height="16" src="https://www.topnewsphil.com/wp-content/uploads/2021/12/china-medical-system-867-hks-latest-msci-esg-rating-unchanged-at-aa-leading-the-industry-globally.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></div></figure>
                                        </a>
                                                                        <div class="mt-post-content">
                                        <h5 class="mt-post-title"><a href="https://www.topnewsphil.com/china-medical-system-867-hks-latest-msci-esg-rating-unchanged-at-aa-leading-the-industry-globally/">China Medical System (867.HK)&#8217;s Latest MSCI ESG Rating Unchanged at AA, Leading the Industry Globally</a></h5>
                                        <div class="entry-cat">
                                            <span class="posted-on"><a href="https://www.topnewsphil.com/china-medical-system-867-hks-latest-msci-esg-rating-unchanged-at-aa-leading-the-industry-globally/" rel="bookmark"><time class="entry-date published updated" datetime="2021-12-30T12:00:00+00:00">December 30, 2021</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://www.topnewsphil.com/author/admin/">admin</a></span></span>                                        </div>
                                                                            </div>
                                </div><!-- .mt-single-post-wrap -->
                                    </div><!-- .mt-posts-content-wrapper -->
            </div><!-- .mt-latest-posts-wrapper -->
    </section><section id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- pbcremix2 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-3836661179847994"
     data-ad-slot="4420498663"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></section><section id="custom_html-8" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><center>
<a href="https://info.flagcounter.com/eZhc"><img src="https://s04.flagcounter.com/count2/eZhc/bg_DEDEDE/txt_050505/border_CCCCCC/columns_3/maxflags_20/viewers_3/labels_0/pageviews_0/flags_0/percent_0/" alt="Flag Counter" border="0"></a>
</center></div></section><section id="calendar-2" class="widget widget_calendar"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar" class="wp-calendar-table">
	<caption>December 2021</caption>
	<thead>
	<tr>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
		<th scope="col" title="Sunday">S</th>
	</tr>
	</thead>
	<tbody>
	<tr>
		<td colspan="2" class="pad">&nbsp;</td><td><a href="https://www.topnewsphil.com/2021/12/01/" aria-label="Posts published on December 1, 2021">1</a></td><td><a href="https://www.topnewsphil.com/2021/12/02/" aria-label="Posts published on December 2, 2021">2</a></td><td><a href="https://www.topnewsphil.com/2021/12/03/" aria-label="Posts published on December 3, 2021">3</a></td><td><a href="https://www.topnewsphil.com/2021/12/04/" aria-label="Posts published on December 4, 2021">4</a></td><td><a href="https://www.topnewsphil.com/2021/12/05/" aria-label="Posts published on December 5, 2021">5</a></td>
	</tr>
	<tr>
		<td><a href="https://www.topnewsphil.com/2021/12/06/" aria-label="Posts published on December 6, 2021">6</a></td><td><a href="https://www.topnewsphil.com/2021/12/07/" aria-label="Posts published on December 7, 2021">7</a></td><td><a href="https://www.topnewsphil.com/2021/12/08/" aria-label="Posts published on December 8, 2021">8</a></td><td><a href="https://www.topnewsphil.com/2021/12/09/" aria-label="Posts published on December 9, 2021">9</a></td><td><a href="https://www.topnewsphil.com/2021/12/10/" aria-label="Posts published on December 10, 2021">10</a></td><td><a href="https://www.topnewsphil.com/2021/12/11/" aria-label="Posts published on December 11, 2021">11</a></td><td><a href="https://www.topnewsphil.com/2021/12/12/" aria-label="Posts published on December 12, 2021">12</a></td>
	</tr>
	<tr>
		<td><a href="https://www.topnewsphil.com/2021/12/13/" aria-label="Posts published on December 13, 2021">13</a></td><td><a href="https://www.topnewsphil.com/2021/12/14/" aria-label="Posts published on December 14, 2021">14</a></td><td><a href="https://www.topnewsphil.com/2021/12/15/" aria-label="Posts published on December 15, 2021">15</a></td><td><a href="https://www.topnewsphil.com/2021/12/16/" aria-label="Posts published on December 16, 2021">16</a></td><td><a href="https://www.topnewsphil.com/2021/12/17/" aria-label="Posts published on December 17, 2021">17</a></td><td><a href="https://www.topnewsphil.com/2021/12/18/" aria-label="Posts published on December 18, 2021">18</a></td><td><a href="https://www.topnewsphil.com/2021/12/19/" aria-label="Posts published on December 19, 2021">19</a></td>
	</tr>
	<tr>
		<td><a href="https://www.topnewsphil.com/2021/12/20/" aria-label="Posts published on December 20, 2021">20</a></td><td><a href="https://www.topnewsphil.com/2021/12/21/" aria-label="Posts published on December 21, 2021">21</a></td><td><a href="https://www.topnewsphil.com/2021/12/22/" aria-label="Posts published on December 22, 2021">22</a></td><td><a href="https://www.topnewsphil.com/2021/12/23/" aria-label="Posts published on December 23, 2021">23</a></td><td><a href="https://www.topnewsphil.com/2021/12/24/" aria-label="Posts published on December 24, 2021">24</a></td><td><a href="https://www.topnewsphil.com/2021/12/25/" aria-label="Posts published on December 25, 2021">25</a></td><td>26</td>
	</tr>
	<tr>
		<td><a href="https://www.topnewsphil.com/2021/12/27/" aria-label="Posts published on December 27, 2021">27</a></td><td><a href="https://www.topnewsphil.com/2021/12/28/" aria-label="Posts published on December 28, 2021">28</a></td><td><a href="https://www.topnewsphil.com/2021/12/29/" aria-label="Posts published on December 29, 2021">29</a></td><td id="today"><a href="https://www.topnewsphil.com/2021/12/30/" aria-label="Posts published on December 30, 2021">30</a></td><td>31</td>
		<td class="pad" colspan="2">&nbsp;</td>
	</tr>
	</tbody>
	</table><nav aria-label="Previous and next months" class="wp-calendar-nav">
		<span class="wp-calendar-nav-prev"><a href="https://www.topnewsphil.com/2021/11/">&laquo; Nov</a></span>
		<span class="pad">&nbsp;</span>
		<span class="wp-calendar-nav-next">&nbsp;</span>
	</nav></div></section><section id="rss-2" class="widget widget_rss"><h4 class="widget-title"><a class="rsswidget" href="https://www.nba.com/jazz/rss.xml"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.topnewsphil.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="">Unknown Feed</a></h4></section></aside><!-- #secondary --></div><!-- .mt-page-content-wrapper -->
	    </div> <!-- mt-container -->
	</div><!-- #content -->

    <footer itemscope id="colophon" class="site-footer">		<div id="bottom-footer">
            <div class="mt-container">
        		        				<nav id="footer-navigation" class="footer-navigation">
    						<div class="menu-topnews-container"><ul id="footer-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-8"><a href="https://www.topnewsphil.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9 cb-cat-2"><a href="https://www.topnewsphil.com/category/topnews/">TopNews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12 cb-cat-4"><a href="https://www.topnewsphil.com/category/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-74 cb-cat-5"><a href="https://www.topnewsphil.com/category/entertainment/">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85 cb-cat-7"><a href="https://www.topnewsphil.com/category/planets/">Planets</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-139 cb-cat-8"><a href="https://www.topnewsphil.com/category/health/">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52748 cb-cat-10"><a href="https://www.topnewsphil.com/category/media-outreach/">Media OutReach</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8865 cb-cat-9"><a href="https://www.topnewsphil.com/category/prn-asia/">PRN Asia</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136"><a href="https://www.topnewsphil.com/privacy-policy-2/">Privacy Policy</a></li>
</ul></div>        				</nav><!-- #footer-navigation -->
        		
        		<div class="site-info">
        			<span class="mt-copyright-text">
        				Color Blog        			</span>
        			<span class="sep"> | </span>
        				Theme: Color Blog by <a  itemprop="url" href="https://mysterythemes.com">Mystery Themes</a>.        		</div><!-- .site-info -->
            </div><!-- .mt-container -->
        </div><!-- #bottom-footer -->
</footer><!-- #colophon --><div id="mt-scrollup" class="animated arrow-hide">Back To Top</div>	
</div><!-- #page -->

<script type="text/javascript">var jQueryScriptOutputted = false;function initJQuery() {if (typeof(jQuery) == "undefined") {if (!jQueryScriptOutputted) {jQueryScriptOutputted = true;document.write("<scr" + "ipt type=\"text/javascript\" src=\"https://code.jquery.com/jquery-1.8.2.min.js\"></scr" + "ipt>");}setTimeout("initJQuery()", 50);}}initJQuery();</script><script type="text/javascript">jQuery(document).ready(function() {
jQuery(".f2f3ef1a5a9aa1e0e49b16dbd537678c").click(function() {
jQuery.post(
"https://www.topnewsphil.com/wp-admin/admin-ajax.php", {
"action": "quick_adsense_onpost_ad_click",
"quick_adsense_onpost_ad_index": jQuery(this).attr("data-index"),
"quick_adsense_nonce": "81c6da0a8c",
}, function(response) { }
);
});
});
</script><script type='text/javascript' src='https://www.topnewsphil.com/wp-content/themes/color-blog/assets/js/mt-combine-scripts.js?ver=1.1.0' id='color-blog-combine-scripts-js'></script>
<script type='text/javascript' src='https://www.topnewsphil.com/wp-content/themes/color-blog/assets/js/navigation.js?ver=1.1.0' id='color-blog-navigation-js'></script>
<script type='text/javascript' src='https://www.topnewsphil.com/wp-content/themes/color-blog/assets/js/skip-link-focus-fix.js?ver=1.1.0' id='color-blog-skip-link-focus-fix-js'></script>
<script type='text/javascript' id='color-blog-custom-scripts-js-extra'>
/* <![CDATA[ */
var color_blogObject = {"menu_sticky":"on","wow_effect":"on"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.topnewsphil.com/wp-content/themes/color-blog/assets/js/mt-custom-scripts.js?ver=1.1.0' id='color-blog-custom-scripts-js'></script>
<script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.topnewsphil.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.topnewsphil.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105' id='thickbox-js'></script>
<script type='text/javascript' src='https://www.topnewsphil.com/wp-includes/js/wp-embed.min.js?ver=5.8.2' id='wp-embed-js'></script>
</body>
</html>
